通达信 黄金比例分割 主图指标

互联网 通达信公式 2019-07-04 15:23:15 0 黄金分割  

实收价:=IF((FRACPART((C * 100)) > 0.46),(CEILING((C * 100)) / 100),(FLOOR((C * 100)) / 100));
柒%阳:=(实收价 >= IF((FRACPART(((REF(实收价,1) * 1.07) * 100)) > 0.46),(CEILING(((REF(实收价,1) * 1.07) * 100)) / 100),(FLOOR(((REF(实收价,1) * 1.07) * 100)) / 100)));
涨停:=(实收价 >= IF((FRACPART(((REF(实收价,1) * 1.1) * 100)) > 0.46),(CEILING(((REF(实收价,1) * 1.1) * 100)) / 100),(FLOOR(((REF(实收价,1) * 1.1) * 100)) / 100)));
跌停:=(实收价 <= IF((FRACPART(((REF(实收价,1) * 0.9) * 100)) > 0.46),(CEILING(((REF(实收价,1) * 0.9) * 100)) / 100),(FLOOR(((REF(实收价,1) * 0.9) * 100)) / 100)));
二十均线:=(INTPART((MA(C,20) * 100)) / 100);
站稳状态:=(SUM((C >= 二十均线),4) = 4);
跌破状态:=(SUM((C <= 二十均线),4) = 4);
站稳确立:=CROSS(站稳状态,0.5);
跌破确立:=CROSS(跌破状态,0.5);
上涨浪:=((((BARSLAST(站稳确立) < BARSLAST(跌破确立)) && (BARSLAST(站稳确立) >= 0)) || 
((BARSLAST(跌破确立) = -(1)) && (BARSLAST(站稳确立) >= 0))) || (((BARSLAST(跌破确立) = -(1)) && (BARSLAST(站稳确立) = -(1))) && (C > 二十均线)));
下跌浪:=((((BARSLAST(跌破确立) < BARSLAST(站稳确立)) && (BARSLAST(跌破确立) >= 0))
 || ((BARSLAST(站稳确立) = -(1)) && (BARSLAST(跌破确立) >= 0))) || (((BARSLAST(跌破确立) = -(1)) && (BARSLAST(站稳确立) = -(1))) && (C <二十均线)));

SJS:=IF(DATE<=130170917,1,0);{均线时间限制函数30-09-17}
MA5:IF(SJS>0,(INTPART((MA(CLOSE,5) * 100)) / 100),0)COLORWHITE,LINETHICK2;
MA10:=IF(SJS>0,(INTPART((MA(CLOSE,10) * 100)) / 100),0)COLORYELLOW,DOTLINE;
MA20:IF(SJS>0,(INTPART((MA(CLOSE,20) * 100)) / 100),0)COLORRED,LINETHICK2;
MA250:MA(CLOSE,250)DOTLINE;

稳:=CROSS(上涨浪,0.5);
破:=CROSS(下跌浪,0.5);
稳日:=BARSLAST(CROSS(上涨浪,0.5));
破日:=BARSLAST(CROSS(下跌浪,0.5));
站稳:=IF(上涨浪,(稳日 + 1),(-(破日) - 1)),COLORYELLOW,LINETHICK0;
不破20日:=((站稳 > 0) && (站稳状态 = 1));

T1:=BARSLAST((稳 = 1));
T2:=BARSLAST((破 = 1));
低点点:=IF((T1 = 0),LLV(L,(T2 + 8)),0);
高点点:=IF((T2 = 0),HHV(H,(T1 + 8)),0);
低收点点:=IF((T1 = 0),LLV(C,(T2 + 8)),0);
高收点点:=IF((T2 = 0),HHV(C,(T1 + 8)),0);
低点黄:=IF((T2 > T1),REF(SUM(低点点,(T1 + 1)),(T1 + 1)),SUM(低点点,(T1 + 1)));
高点原:=SUM(高点点,(T2 + 1));
低点原:=SUM(低点点,(T1 + 1));
SJS1:=DATE > 1300917;
低点:=IF(SJS1,0,IF(((FRACPART((低点黄 * 100)) * 10) > 4.6),(CEILING((低点黄 * 100)) / 100),(INTPART((低点黄 * 100)) / 100))),COLORYELLOW,NODRAW;
STICKLINE(CURRBARSCOUNT=13,低点,低点,700,1),COLORYELLOW;

%1:=IF(SJS1,0,IF(((FRACPART((高点原 * 100)) * 10) > 4.6),(CEILING((高点原 * 100)) / 100),(INTPART((高点原 * 100)) / 100))),COLORYELLOW,NODRAW;
STICKLINE(CURRBARSCOUNT=13,%1,%1,700,1),COLORYELLOW;

%0.382:=(INTPART(((低点 + ((%1 - 低点) * 0.382)) * 100)) / 100),COLORGREEN,NODRAW;
STICKLINE(CURRBARSCOUNT=13,%0.382,%0.382,700,1),COLORGREEN;

%0.618:=(INTPART(((低点 + ((%1 - 低点) * 0.61803)) * 100)) / 100),COLORMAGENTA,NODRAW;
STICKLINE(CURRBARSCOUNT=13,%0.618,%0.618,700,1),COLORMAGENTA;

%1.618:=(INTPART(((低点 + ((%1 - 低点) * 1.61803)) * 100)) / 100),COLORRED,NODRAW;
STICKLINE(CURRBARSCOUNT=13,%1.618,%1.618,700,1),COLORRED;

TT:=BACKSET(BARSTATUS=2 , 2);
TTT:=FILTER(TT ,3);
{爱股吧--WWW.IGUBAR.COM}
DRAWTEXT(TTT,%1,'前高'),COLORYELLOW;
DRAWTEXT(TTT,%0.382,'0.382'),COLORGREEN;
DRAWTEXT(TTT,%0.618,'0.618'),COLORMAGENTA;
DRAWTEXT(TTT,低点,'低点'),COLORYELLOW;
DRAWTEXT(TTT,%1.618,'1.618'),COLORRED;

T1T:=BACKSET(BARSTATUS=2,30);
TT1T:=FILTER(T1T ,30);
DRAWNUMBER(TT1T,%1.618,%1.618),COLORRED;
DRAWNUMBER(TT1T,低点*0.015+低点,低点),COLORYELLOW;
DRAWNUMBER(TT1T,%0.618,%0.618),COLORMAGENTA;
DRAWNUMBER(TT1T,%0.382,%0.382),COLORGREEN;
DRAWNUMBER(TT1T,%1,%1),COLORYELLOW;
IF(上涨浪 AND SJS>0,MA20,DRAWNULL),LINETHICK2,COLORRED;
IF(下跌浪 AND SJS>0,MA20,DRAWNULL),LINETHICK2,COLORGREEN; 
 



含未来函数,请谨慎使用。

版权声明

爱股吧所有金融分析软件的指标公式及文章均来自互联网分享,仅供学习与研究,请勿以此为依据进行金融交易。
如有版权问题请及时联系,我们将及时为您处理不符合的内容。
版权投诉与广告投放QQ:310494077

分享:

扫一扫在手机阅读、分享本文

留言与评论(共有 条评论)
   
验证码: