同花顺主图 三色均线 主图指标公式

互联网 同花顺公式 2019-06-23 16:37:37 0 三色均线  主图指标  
mc:=(C+ H +L + O)/4;
K1:=EMA(mc,3);
K2:=EMA(mc,5) ;
K3:=EMA(mc,8) ;
K4:=EMA(mc,13) ;
K5:=EMA(mc,15);
K6:=EMA(mc,30);
K7:=EMA(mc,35);
K8:=EMA(mc,40);
K9:=EMA(mc,45) ;
K10:=EMA(mc,50) ;
K11:=EMA(mc,60);

K120:=EMA(mc, 120);
PARTLINE(K120,K120>REF(K120,1),colorred,K120<REF(K120,1),RGB(0,255,0));

a1:=MAX(K6,K7);
a2:=MAX(a1,K8);
a3:=MAX(a2,K9);
a4:=MAX(a3,K10);
a5:=MAX(a4,K11);
b1:=MIN(K6,K7);
b2:=MIN(b1,K8);
b3:=MIN(b2,K9);
b4:=MIN(b3,K10);
b5:=MIN(b4,K11);

//MiddleMM:= (K6 + K7 + K8 + K9 + K10 + K11)/6;

MAXM:= MAX(K6, K7);
MAXM:= MAX(K7, K8);
MAXM:= MAX(K8, K9);
MAXM:= MAX(K9, K10);
MAXM:= MAX(K10, K11);

MINM:= MIN(K6, K7);
MINM:= MIN(K7, K8);
MINM:= MIN(K8, K9);
MINM:= MIN(K9, K10);
MINM:= MIN(K10, K11);

weight:= ABS(MAXM-MINM);
Mred:=(K6- K11 > 0 AND weight > REF(weight, 1)) OR (K6 - K11 < 0 AND weight < REF(weight, 1));
Mblue:=(K6- K11 > 0 AND weight < REF(weight, 1)) OR (K6- K11 < 0 AND weight > REF(weight, 1));

//MAXN:= MAX(K1, K2); MAXN:= MAX(K2, K3);MAXN:= MAX(K3, K4);MAXN:= MAX(K4, K5);MINN:= MIN(K1, K2);MINN:= MIN(K2, K3);MINN:= MIN(K3, K4);MINN:= MIN(K4, K5); nweight:= ABS(MAXn-MINN);Nred:=(K1- K5 > 0 AND nweight >= REF(nweight, 1) ) OR (K1- K5 < 0 AND nweight < REF(nweight, 1)); //Nblue:=(K1- K5 > 0 AND nweight < REF(nweight, 1)) OR (K1- K5 < 0 AND nweight > REF(nweight, 1));nblue:= 1-2> 0;FILLRGN( K1, K2 ,nred,RGB(30,0, 0),nblue,RGB(0,0,20));FILLRGN( K2, K3 ,nred, RGB(30,0,0),nblue,RGB(0,0,20));FILLRGN( K3, K4 ,nred,RGB(30,0,0),nblue,RGB(0,0,20));FILLRGN( K4, K5 ,nred,RGB(30,0,0),nblue,RGB(0,0,20));

PARTLINE(K1,K1>REF(K1,1),RGB(130,130,0),K1<REF(K1,1),RGB(0,0,130));
PARTLINE(K2,K2>REF(K2,1),RGB(130,130,0),K2<REF(K2,1),RGB(0,0,130));
PARTLINE(K3,K3>REF(K3,1),RGB(130,130,0),K3<REF(K3,1),RGB(0,0,130));
PARTLINE(K4,K4>REF(K4,1),RGB(130,130,0),K4<REF(K4,1),RGB(0,0,130));
PARTLINE(K5,K5>REF(K5,1),RGB(130,130,0),K5<REF(K5,1),RGB(0,0,130));


PARTLINE(K6,K6>REF(K6,1),RGB(130,0,0),K6<REF(K6,1),RGB(0,0,130));
PARTLINE(K7,K7>REF(K7,1),RGB(130,0,0),K7<REF(K7,1),RGB(0,0,130));
PARTLINE(K8,K8>REF(K8,1),RGB(130,0,0),K8<REF(K8,1),RGB(0,0,130));
PARTLINE(K9,K9>REF(K9,1),RGB(130,0,0),K9<REF(K9,1),RGB(0,0,130));
PARTLINE(K10,K10>REF(K10,1),RGB(130,0,0),K10<REF(K10,1),RGB(0,0,130));
PARTLINE(K11,K11>REF(K11,1),RGB(130,0,0),K11<REF(K11,1),RGB(0,0,130));

//MAa: MA120 * (100 + 13)/100, coloryellow;
//MAb: MA120 * (100 - 13)/100, coloryellow;

//b:=(HHV(C, 20)- LLV(C,20)) *200/(HHV(C, 20)+ LLV(C,20)) <9;
//DRAWTEXT(b, HHV(C, 20),'---------');
//DRAWTEXT(b, LLV(C, 20),'---------');


//大均线呈45度角时候买入

mc:=(C+ H +L + O)/4;

K1:=EMA(mc,3);
K2:=EMA(mc,5) ;
K3:=EMA(mc,8) ;
K4:=EMA(mc,13) ;
K5:=EMA(mc,15);
K6:=EMA(mc,30);
K7:=EMA(mc,35);
K8:=EMA(mc,40);
K9:=EMA(mc,45) ;
K10:=EMA(mc,50) ;
K11:=EMA(mc,60);

K120:=EMA(mc, 120);
PARTLINE(K120,K120>REF(K120,1),colorred,K120<REF(K120,1),RGB(0,255,0));



a1:=MAX(K6,K7);
a2:=MAX(a1,K8);
a3:=MAX(a2,K9);
a4:=MAX(a3,K10);
a5:=MAX(a4,K11);


b1:=MIN(K6,K7);
b2:=MIN(b1,K8);
b3:=MIN(b2,K9);
b4:=MIN(b3,K10);
b5:=MIN(b4,K11);

//MiddleMM:= (K6 + K7 + K8 + K9 + K10 + K11)/6;

MAXM:= MAX(K6, K7);
MAXM:= MAX(K7, K8);
MAXM:= MAX(K8, K9);
MAXM:= MAX(K9, K10);
MAXM:= MAX(K10, K11);

MINM:= MIN(K6, K7);
MINM:= MIN(K7, K8);
MINM:= MIN(K8, K9);
MINM:= MIN(K9, K10);
MINM:= MIN(K10, K11);

weight:= ABS(MAXM-MINM);
Mred:=(K6- K11 > 0 AND weight > REF(weight, 1)) OR (K6 - K11 < 0 AND weight < REF(weight, 1));
Mblue:=(K6- K11 > 0 AND weight < REF(weight, 1)) OR (K6- K11 < 0 AND weight > REF(weight, 1));

//MAXN:= MAX(K1, K2); MAXN:= MAX(K2, K3);MAXN:= MAX(K3, K4);MAXN:= MAX(K4, K5);MINN:= MIN(K1, K2);MINN:= MIN(K2, K3);MINN:= MIN(K3, K4);MINN:= MIN(K4, K5); nweight:= ABS(MAXn-MINN);Nred:=(K1- K5 > 0 AND nweight >= REF(nweight, 1) ) OR (K1- K5 < 0 AND nweight < REF(nweight, 1)); //Nblue:=(K1- K5 > 0 AND nweight < REF(nweight, 1)) OR (K1- K5 < 0 AND nweight > REF(nweight, 1));nblue:= 1-2> 0;FILLRGN( K1, K2 ,nred,RGB(30,0, 0),nblue,RGB(0,0,20));FILLRGN( K2, K3 ,nred, RGB(30,0,0),nblue,RGB(0,0,20));FILLRGN( K3, K4 ,nred,RGB(30,0,0),nblue,RGB(0,0,20));FILLRGN( K4, K5 ,nred,RGB(30,0,0),nblue,RGB(0,0,20));

PARTLINE(K1,K1>REF(K1,1),RGB(130,130,0),K1<REF(K1,1),RGB(0,0,130));
PARTLINE(K2,K2>REF(K2,1),RGB(130,130,0),K2<REF(K2,1),RGB(0,0,130));
PARTLINE(K3,K3>REF(K3,1),RGB(130,130,0),K3<REF(K3,1),RGB(0,0,130));
PARTLINE(K4,K4>REF(K4,1),RGB(130,130,0),K4<REF(K4,1),RGB(0,0,130));
PARTLINE(K5,K5>REF(K5,1),RGB(130,130,0),K5<REF(K5,1),RGB(0,0,130));


PARTLINE(K6,K6>REF(K6,1),RGB(130,0,0),K6<REF(K6,1),RGB(0,0,130));
PARTLINE(K7,K7>REF(K7,1),RGB(130,0,0),K7<REF(K7,1),RGB(0,0,130));
PARTLINE(K8,K8>REF(K8,1),RGB(130,0,0),K8<REF(K8,1),RGB(0,0,130));
PARTLINE(K9,K9>REF(K9,1),RGB(130,0,0),K9<REF(K9,1),RGB(0,0,130));
PARTLINE(K10,K10>REF(K10,1),RGB(130,0,0),K10<REF(K10,1),RGB(0,0,130));
PARTLINE(K11,K11>REF(K11,1),RGB(130,0,0),K11<REF(K11,1),RGB(0,0,130));
//爱股吧公式网igubar.com
//MAa: MA120 * (100 + 13)/100, coloryellow;
//MAb: MA120 * (100 - 13)/100, coloryellow;

//b:=(HHV(C, 20)- LLV(C,20)) *200/(HHV(C, 20)+ LLV(C,20)) <9;
//DRAWTEXT(b, HHV(C, 20),'---------');
//DRAWTEXT(b, LLV(C, 20),'---------');

//大均线呈45度角时候买入

版权声明

爱股吧所有金融分析软件的指标公式及文章均来自互联网分享,仅供学习与研究,请勿以此为依据进行金融交易。
如有版权问题请及时联系,我们将及时为您处理不符合的内容。
版权投诉与广告投放QQ:310494077

下一篇 :返回列表

分享:

扫一扫在手机阅读、分享本文

留言与评论(共有 条评论)
   
验证码: